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Trend of Digital Gaming Industry
 Employment has grown by 9.3% in 2021. 

 Revenues have jumped by 30% after the COVID-19 pandemic.

 Games are available in all platforms.

 Players have more choices.

 E-sports is growing in popularity. There are 8,600 US high school teams.

 More schools, colleges, and universities have established gaming 
programs and courses.

 Gaming programs help attract students and increase enrollment.



Objectives
 Design a basic game

 Apply terrain

 Add objects

 Playtest and tweak

Downloads
 Go to https://unity3d.com/get-unity/download/archive > Select the tab 2018 > Scroll down to 

select 2018.1.1f1 > Go to Downloads (Win/Mac) pull-down menu > Select Unity Installer > 
Run UnityDownloadAssistant-2018.1.1f1.exe > Select/check these three items, Unity 
2018.1.1f1, Documentation, and Standard Assets > Follow the instructions and complete the 
installation.

 Download MonoDevelop code editor (Win/Mac) from https://www.mono-
project.com/download/stable/ with GTK# (32 bit, 1st left link for Win/your (attendees) 
preference for Mac) and follow the instructions.

 Download Unity Hub (optional): https://unity3d.com/get-unity/download

https://unity3d.com/get-unity/download/archive
https://www.mono-project.com/download/stable/
https://unity3d.com/get-unity/download


Design
 Process: Plan, research, blueprint/storyboard/layout, develop, test, 

debug, finalize.
 Planning—3 stages: (1) Concept, (2) Rules, (3) Requirements

 Concept: Start from one end and finish at the other end by avoiding obstacles.

 Goal: How fast can you make it to the finish zone.

 Rules:

 Purposes—2: (1) Let player know how to play the game, rewards, win-loss 
conditions, and so on, (2) Software is the process of permission means if you want a 
player to do certain actions you have to build in.

1. No win-loss condition

2. The player will always spawn in the same spot and the finish zone at the same 
spot.

3. Water hazards. If the player falls into a water hazard, have to restart or moved back 
to the spawn point.

4. Objective: finish as quickly as possible. There will be cues.



Design
 Process > Planning > Rules (cont)

 Rules:

 Terminology

 Spawn: is the process by which a player enters a game.

 Spawn Point: is the place where a player spawns.

 Condition: is form of trigger. Win or loss.

 Game Controller: dictates the rules and flow of a game.

 Playtesting: play and test the unfinished game to improve it.

 Requirements:

1. Terrain

2. Textures and environment

3. Objects: Spawn point, finish zone, and water hazard.

4. Character controller

5. Graphical User Interface (GUI)

6. Game Manager/Controller



Creating the Game World
1. Sculpting the World

2. Adding the Environment

3. Character Controller

 Gamification: is the process of turning something into a game by applying 
game rules and goal.

4. Game Control Objects

5. Adding Scripts

6. Connecting Scripts

 Playtesting

 Tips: 1. Exit from playing within Unity: Click on Esc. 2. Exit after playing the 
game Application (executable file): There are two options: a. Press Alt+F4 or 
b. Press a Windows key > R-click on the Unity icon in the Task Bar > Click on 
Close Window.
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Instructions for Downloading Unity 2018.1.1f1 

1. Go to https://unity3d.com/get-unity/download/archive > Select the tab 2018 > Scroll down to 

select 2018.1.1f1 > Go to Downloads (Win/Mac) pull-down menu > Select Unity Installer > Run 

UnityDownloadAssistant-2018.1.1f1.exe > Select/check these three items, Unity 2018.1.1f1, 

Documentation, and Standard Assets > Follow the instructions and complete the installation. 

Instructions for Downloading MonoDevelop Code Editor 

Download MonoDevelop code editor (Win/Mac) from https://www.mono-

project.com/download/stable/ with GTK# (32 bit, 1st left link for Win/your (attendees) preference for 

Mac) and follow the instructions. 

1. Download, unzip, and place the unzipped MonoDevelop folder in the Program Files of C: drive. 
2. Unity > Edit > Preferences > External Tools > Browse > Program Files > MonoDevelop > Bin > 

MonoDevelop (application, light blue icon). 
3. If this doesn't work and you get the error message regarding GTK#, go to MonoDevelop > 

GTKSharp > Run the Window Installer app "gtk-sharp." 

 

Amazing Racer Game 

Review the existing Unity game and its application file from the shared folder. 

Tips: 1. Exit from playing within Unity: Click on Esc. 2. Exit after playing the game Application (executable 

file): There are two options: a. Press Alt+F4 or b. Press a Windows key > R-click on the Unity icon in the 

Task Bar > Click on Close Window. 

Sculpting the World (see Fig 1: The general terrain layout for the game Amazing Racer.) 

https://unity3d.com/get-unity/download/archive
https://www.mono-project.com/download/stable/
https://www.mono-project.com/download/stable/
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To sculpt the terrain, follow these steps: 

1. Create a new project as Project Name: 3D Game_Amazing Racer, Location: your choice, Template: 3D 

> Click on Create Project. Note: If you don’t have a Unity account, please create it.  

2. Rename the Sample Scene file to Main.  

3. Add a terrain from Game Object > 3D Object > Terrain and position its transform at (0, 0, 0) in the 

Inspector. 

4. Locate the file Terrain.raw in the given folder. Import the Terrain.raw file as a heightmap for the 

terrain (by clicking Import Raw in the Heightmap section under Terrain Settings in the Inspector). 

5. Leave the Depth, Width, and Height settings as they are. Keep the default Byte Order to Windows or 

change Byte Order to Mac and set Terrain Size/Resolution to 200 wide (x) by 200 long (z) by 100 

tall/height (y). 

6. Save the current Main scene. 

Adding the Environment 

Assets > Import Package > Environment > All must be selected > Import. [It will take a few minutes.] 

1. You may rotate the directional light to suit your preference. 

2. Texture the terrain. The sample project uses the following textures: GrassHillAlbedo for flat parts, 

CliffAlbedoSpecular for steep parts, GrassRockyAlbedo for the areas in between, and 

MudRockyAlbedoSpecular for inside the pits. 

Inspector > Terrain > Paint Texture (4th icon) > Select Brushes > Edit Textures > Add Textures > Click on a 

Cog circular icon > Select textures from the list or type few letters in Search to find a texture. > Click Add 

> The selected texture will be highlighted in blue. > Set Texture Settings as per your desire. 

3. Raise/lower the terrain. Inspector > Terrain > Raise/Lower Terrain (1th icon) > Change the terrain to 

your liking by selecting desired Brushes and Settings.  

4. Add trees to your terrain. Trees should be placed sparsely and mostly on flat surfaces. Inspector > 

Terrain > Paint Trees (5th icon) > Edit Trees > Add Tree > Click on a Cog circular icon > Select trees from 
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the list or type few letters in Search to find a tree. > Click Add > The selected tree will be highlighted in 

blue. > Set Tree Settings as per your desire.  

5. Add some water to your scene from the Environment assets. Locate the Water4Advanced prefab in 

the folder Assets\Standard Assets\Environment\Water\Water4\Prefabs and drag it into your scene. 

Position the water at (100, 1.8, 100) and scale it to (2, 1, 2). Alert: Position and scale water according to 

your sculpting. You may have more than one Water4Advanced prefabs. 

Error: “SpeedTree materials need to be regenerated.” Try to regenerate them in Inspector. You need to 

regenerate the assets. Steps: Navigate to the assets in the asset folder and click on them (materials with 

an arrow) to bring up the inspector. There will be an option in the inspector to regenerate the asset. 

Saving the project, closing it and reopening should work also as this is due to Unity recreating the library 

folder for the import which is a standard behavior for Unity. 

Fog 

1. Select Window > Lighting > Settings. The Lighting window opens. 

2. Turn on fog by checking the Fog check box under Other Settings. 

3. Change the color to white and set the density to 0.005. (Note: These are arbitrary values and can be 

changed (or omitted) based on your preferences.) 

4. Experiment with the different fog densities and colors.  

Skyboxes 

1. Right-click the Project view and select Create > Material. (Skyboxes are really just materials applied to 

a “giant box in the sky.”) 

2. In the Inspector for this new material, click the Shader drop-down and select Skybox (9th item) > 

Procedural (4th, last item). Note that this is where you can also choose other types of skyboxes. 

3. Apply the skybox to the scene through the Lighting settings window (which you open by selecting 

Window > Lighting > Settings).  

The Character Controller 

1. Import the standard character controllers by selecting Assets > Import Package > Characters > Import. 

2. Locate the FPSController asset in the folder Assets\Standard 

Assets\Characters\FirstPersonCharacter\Prefabs and drag it into your scene. 

3. Position the controller (which is named FPSController and is blue in the Hierarchy view) at (165, 32, 

125). If the controller doesn’t seem to be positioned correctly on the terrain, ensure that the terrain is 

positioned at (0, 0, 0), as per the previous exercise. Now rotate the controller to 260 on the y axis so 

that it faces the correct direction. Rename the controller object Player. 

4. Because the Player controller has its own camera, delete the Main Camera from the scene. (see Fig 2) 
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Adding Game Control Objects 

To create the spawn point, follow these steps: 

1. Add an empty game object to the scene (by selecting GameObject > Create Empty). 

2. Position the game object at (165, 32, 125) and give it a rotation of (0, 260, 0). 

3. Rename the empty object Spawn Point in the Hierarchy view. 

To create the water hazard detector, follow these steps: 

1. Add a plane to the scene (by selecting GameObject > 3D Object > Plane) and position it at (100, 0, 

100). Scale the plane to (20, 1, 20). Alert: Position and scale underneath water. 

2. Rename the plane Water Hazard Detector in the Hierarchy view. 

3. Check the Convex and Is Trigger check boxes on the Mesh Collider component in the Inspector view. 

4. Make the object invisible by disabling its Mesh Renderer component. Do this by unchecking the box 

next to the Mesh Renderer component’s name in the Inspector. (see Fig 3) 
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To add the Finish Zone object, follow these steps: 

1. Add an empty game object to the scene and position it at (26, 32, 37). 

2. Rename the object Finish Zone in the Hierarchy view. 

3. Add a light component to the Finish Zone object. (With the object selected, click Component > 

Rendering > Light.) Change the type to Point if it isn’t already set to this and set the range to 35 and 

intensity to 3. Pick your own color. 

4. Add a capsule collider to the Finish Zone object by selecting the object and clicking Component > 

Physics > Capsule Collider. Check the Is Trigger check box and change the Radius property to 9 in the 

Inspector view. (see Fig 4) 
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To create the Game Manager object, follow these steps: 

1. Add an empty game object to the scene. 

2. Rename the game object Game Manager in the Hierarchy view. 

Adding Scripts 

You can add scripts to your project in one of two ways: 

 Drag existing scripts from the existing files into the Project view of your project.  

 Or create new scripts in your project by right-clicking in the Project view and selecting Create > 

C# Script. 
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To apply a script, simply drag it from the Project view onto whatever object you want to apply it to in 

either the Hierarchy view or the Inspector view. (see Fig 5) 

 

Importing and Attaching Scripts 

Follow these steps to import the scripts from the given files and attach them to the correct objects: 

1. Create a new folder in your Project view and name it Scripts. Locate the three scripts in the given files 

files—FinishZone.cs, GameManager.cs, and PlayerRespawn.cs—and drag them into your newly created 

Scripts folder. 

2. Drag the FinishZone.cs script from the Project view onto the Finish Zone game object in the Hierarchy 

view. 

3. Select the Game Manager object in the hierarchy. In the Inspector, select Add Component > Scripts > 

GameManager. (This is an alternative way of adding a script component to a game object.) 

4. Drag the PlayerRespawn.cs script from the Project view onto the Water Hazard Detector game object 

in the hierarchy. 

Connecting Scripts to Scripts 

Follow these steps to give the scripts the game objects they need to function correctly: 

1. Select the Water Hazard Detector object in the Hierarchy view. Notice that the Player Respawn 

component has a Game Manager property. This property is a placeholder for the Game Manager object 

you made previously. 

2. Click and drag the Game Manager object from the Hierarchy view onto the Game Manager property 

of the Player Respawn (Script) component. Now, whenever players fall into the water hazard, the water 

hazard will let the Game Manager object know, and the player will get moved back to the spawn point 

at the beginning of the level. 
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3. Select the Finish Zone game object. Click and drag the Game Manager object from the Hierarchy view 

onto the Game Manager property of the Finish Zone (Script) component in the Inspector view. Now, 

whenever the player enters the finish zone, the game control will be notified. 

4. Select the Game Manager object. Click and drag the Spawn Point object onto the Spawn Point 

property of the Game Manager (Script) component. (see Fig 6) 

5. Click and drag the Player object (this is the character controller) onto the Player property of the Game 

Manager object.  

 

Playtesting and Debugging 

Create an Application File Using Build Settings 

1. Create 3D Game_Amazing Racer_Application in the same location of your game folder in 

Windows Explorer (not using Unity and outside the game folder).  

2. Also, create an executable/application file. File > Build Settings > Drag the scene file in the 

“Scenes in Build” window and check it. (Alert: Make sure the Sample Scene is unchecked or 

delete it.) > Select Platform (PC, Mac, Standalone) and Target Platform (Windows) > Build > 

Select the 3D Game_Amazing Racer_Application.  

3. You will have two game folders, 3D Game_Amazing Racer and 3D Game_Amazing 

Racer_Application.  

4. Alert: To exit after playing the game Application (executable file) there are two options: 1. Press 

Alt+F4 or 2. Press a Windows key > R-click on the Unity icon in the Task Bar > Click on Close 

Window. 
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